Jump to content
Free-reseau.fr - Les forums
topzoe

probleme SMTP depuis passage en OS X Yosemite

Recommended Posts

Bonjour,

je suis passé en OS X Yosemite depuis hier, au début tout allait bien et aujourd'hui rien ne va plus.

Les mails que je veux envoyer restent dans boite d'envoie.

J'utilise le port 25  sans authentification sur smtp.free.fr.

 

Voici le log du client Mail d'OS X:

 

READ Oct 21 18:05:13.513 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6080000a9240 -- thread:0x610000668400

503 5.7.0 Error: access denied for unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51754
 
INITIATING CONNECTION Oct 21 18:05:22.913 host:smtp.free.fr -- port:25 -- socket:0x0 -- thread:0x60800046de80
 
INITIATING CONNECTION Oct 21 18:05:22.913 host:imap.free.fr -- port:993 -- socket:0x0 -- thread:0x608000264880
 
INITIATING CONNECTION Oct 21 18:05:22.928 host:p02-imap.mail.me.com -- port:993 -- socket:0x0 -- thread:0x610000277800
 
CONNECTED Oct 21 18:05:23.073 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
 
READ Oct 21 18:05:23.232 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
554 5.7.1 <unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51755>: Client host rejected: Access denied
 
WROTE Oct 21 18:05:23.239 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
EHLO [iPv6:2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]
 
CONNECTED Oct 21 18:05:23.328 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x608000264880
 
READ Oct 21 18:05:23.356 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x608000264880
* OK IMAP4 ready
 
WROTE Oct 21 18:05:23.357 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
1.12 CAPABILITY
 
READ Oct 21 18:05:23.386 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
* CAPABILITY IMAP4REV1 X-NETSCAPE LOGIN-REFERRALS AUTH=PLAIN
1.12 OK completed
 
WROTE Oct 21 18:05:23.387 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
2.12 AUTHENTICATE PLAIN
 
READ Oct 21 18:05:23.397 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
503 5.7.0 Error: access denied for unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51755
 
WROTE Oct 21 18:05:23.397 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
EHLO [iPv6:2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]
 
READ Oct 21 18:05:23.417 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
 
WROTE Oct 21 18:05:23.418 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
********************************************************************
 
READ Oct 21 18:05:23.456 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
2.12 OK [CAPABILITY IMAP4rev1 ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST] LOGIN completed
 
WROTE Oct 21 18:05:23.458 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
3.12 ID ("name" "Mac OS X Mail" "version" "8.0 (1990.1)" "os" "Mac OS X" "os-version" "10.10 (14A389)" "vendor" "Apple Inc.")
 
READ Oct 21 18:05:23.490 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
* ID ("NAME" "Zimbra" "VERSION" "7.2.0-GA2598" "RELEASE" "20130310233755" "USER" "lilian.payet@free.fr" "SERVER" "84cd80e5-d6fb-402c-9a26-afbf0b37173b")
3.12 OK ID completed
 
WROTE Oct 21 18:05:23.490 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
4.12 LIST "" ""
 
READ Oct 21 18:05:23.520 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x610000668400
* LIST (\NoSelect) "/" ""
4.12 OK LIST completed
 
WROTE Oct 21 18:05:23.521 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:imap.free.fr -- port:993 -- socket:0x6100000bd220 -- thread:0x61000066fbc0
5.12 LOGOUT
 
READ Oct 21 18:05:23.555 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
503 5.7.0 Error: access denied for unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51755
 
WROTE Oct 21 18:05:23.555 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
RSET
 
CONNECTED Oct 21 18:05:23.591 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x610000277800
 
READ Oct 21 18:05:23.710 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x610000277800
* OK [CAPABILITY st11p02mm-iscream003 14G XAPPLEPUSHSERVICE IMAP4 IMAP4rev1 SASL-IR AUTH=ATOKEN AUTH=PLAIN] iSCREAM ready to rumble (14G:4249) st11p02mm-iscream003 [40:7994:16:05:23:DE]
 
WROTE Oct 21 18:05:23.711 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x608000264880
1.13 AUTHENTICATE ATOKEN  (*** 80 bytes hidden ***)
 
READ Oct 21 18:05:23.712 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
503 5.7.0 Error: access denied for unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51755
 
WROTE Oct 21 18:05:23.712 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
HELO [iPv6:2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]
 
READ Oct 21 18:05:23.872 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6180000b47c0 -- thread:0x60800046de80
503 5.7.0 Error: access denied for unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51755
 
INITIATING CONNECTION Oct 21 18:05:23.872 host:smtp.free.fr -- port:25 -- socket:0x0 -- thread:0x60800046de80
 
READ Oct 21 18:05:23.877 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x608000264880
1.13 OK [CAPABILITY XAPPLEPUSHSERVICE IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ NAMESPACE UIDPLUS CHILDREN BINARY UNSELECT SORT CATENATE URLAUTH LANGUAGE ESEARCH ESORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES CONDSTORE ENABLE CONTEXT=SEARCH CONTEXT=SORT WITHIN SASL-IR SEARCHRES XSENDER X-NETSCAPE XSERVERINFO X-SUN-SORT ANNOTATE-EXPERIMENT-1 X-UNAUTHENTICATE X-SUN-IMAP X-ANNOTATEMORE XUM1 ID IDLE] User lilian.payet logged in
 
WROTE Oct 21 18:05:23.879 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x608000264880
2.13 ID ("name" "Mac OS X Mail" "version" "8.0 (1990.1)" "os" "Mac OS X" "os-version" "10.10 (14A389)" "vendor" "Apple Inc.")
 
READ Oct 21 18:05:24.003 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x608000264880
* ID NIL
2.13 OK Completed
 
WROTE Oct 21 18:05:24.003 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x608000264880
3.13 LIST "" ""
 
CONNECTED Oct 21 18:05:24.036 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6000000b2d20 -- thread:0x60800046de80
 
READ Oct 21 18:05:24.126 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x608000264880
* LIST (\Noselect) "/" ""
3.13 OK Completed
 
WROTE Oct 21 18:05:24.126 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:p02-imap.mail.me.com -- port:993 -- socket:0x6180000b97a0 -- thread:0x608000264880
4.13 LOGOUT
 
READ Oct 21 18:05:24.204 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6000000b2d20 -- thread:0x60800046de80
554 5.7.1 <unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51759>: Client host rejected: Access denied
 
WROTE Oct 21 18:05:24.204 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6000000b2d20 -- thread:0x60800046de80
HELO [iPv6:2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]
 
READ Oct 21 18:05:24.360 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6000000b2d20 -- thread:0x60800046de80
503 5.7.0 Error: access denied for unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51759
 
WROTE Oct 21 18:05:24.360 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6000000b2d20 -- thread:0x60800046de80
HELO [iPv6:2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]
 
READ Oct 21 18:05:24.521 [kCFStreamSocketSecurityLevelNone] -- host:smtp.free.fr -- port:25 -- socket:0x6000000b2d20 -- thread:0x60800046de80
503 5.7.0 Error: access denied for unknown[2002:4eed:c64b:e472:c0ea:8ee9:8c98:bef3]:51759
 
 
Merci d'avance.

Share this post


Link to post
Share on other sites

Moi aussi j'ai le même problème.

Impossible d'envoyer avec free.smtp.fr

Il m'indique déconnecté

C'est rassurant de voir que je ne suis pas le seul.

D'autant plus que mon iPad est bien configuré comme mon Mac, mais lui, envoie et reçois les mails sans problème...

C'est peut être un bug dans le client Mail de Yosemite...

Share this post


Link to post
Share on other sites

Bonjour,

Juste   pour  vous  signaler que  nous n'avons pas d'anomalie déclarée  pour le smtp.free.fr.

Cela  doit  provenir de  votre  client Messagerie  comme le fait  rémarquer " topzoe ".

Share this post


Link to post
Share on other sites

Bonjour,

Juste   pour  vous  signaler que  nous n'avons pas d'anomalie déclarée  pour le smtp.free.fr.

Cela  doit  provenir de  votre  client Messagerie  comme le fait  rémarquer " topzoe ".

Quel bordel! avez vous déjà eu des retours d'utilisateurs avec Yosemite?

 

Voila ce que j'obtiens avec le client Mail d'OS X Yosemite:

 

Vérifiez l’adresse du ou des destinataires du message. Vérifiez également les réglages de serveur SMTP dans les préférences Mail ainsi que les réglages avancés auprès de votre administrateur système.

 

La réponse du serveur a été : <unknown[2002:4eed:c64b:e472:fc3d:8c83:af1b:2f9d]:49316>: Client host rejected: Access denied

 

 

Sélectionnez un autre serveur d’envoi dans la liste ci-dessous ou cliquez sur Essayer plus tard pour laisser le message dans votre boîte d’envoi jusqu’à ce qu’il puisse être envoyé.

 

Et pourtant quand je lance un diagnostique de connexion Mail j'ai bien:

 

pour IMAP: Connexion et identification auprès du serveur réalisées avec succès.

et pour SMTP: Connexion au serveur réalisées avec succès, aucune identification requise.

Edited by topzoe

Share this post


Link to post
Share on other sites

Quel bordel! avez vous déjà eu des retours d'utilisateurs avec Yosemite?

 

Voila ce que j'obtiens avec le client Mail d'OS X Yosemite:

 

Vérifiez l’adresse du ou des destinataires du message. Vérifiez également les réglages de serveur SMTP dans les préférences Mail ainsi que les réglages avancés auprès de votre administrateur système.

 

La réponse du serveur a été : <unknown[2002:4eed:c64b:e472:fc3d:8c83:af1b:2f9d]:49316>: Client host rejected: Access denied

 

 

Sélectionnez un autre serveur d’envoi dans la liste ci-dessous ou cliquez sur Essayer plus tard pour laisser le message dans votre boîte d’envoi jusqu’à ce qu’il puisse être envoyé.

 

Et pourtant quand je lance un diagnostique de connexion Mail j'ai bien:

 

pour IMAP: Connexion et identification auprès du serveur réalisées avec succès.

et pour SMTP: Connexion au serveur réalisées avec succès, aucune identification requise.

Bon j'ai trouvé (ou alors contourné le problème)

J'ai activé l'authentification SMTP sur mon interface de gestion FREE.

Et donc dans mon client Mail j'ai mis utilisation du SSL sur le port 465.

Je ne sais pas si cela a un rapport, mais j'ai aussi modifié le mot de passe de mon mail FREE.

Avant j'avais un mot de passe de type ''simple'' , j'en ai mis un de type complexe (Majuscule, minuscule et des chiffres)

Et à présent cela fonctionne, j'arrive à envoyer des mails sur le SMTP de FREE.

 

Cordialement 

Share this post


Link to post
Share on other sites

J'ai eu aussi  un blocage de mes comptes mails free après passage à Yosemite et redémarrage du système:  IMAP et SMTP déconnecté

J'ai fait les manip suivantes et pensé avoir résolu car j'ai récupéré mes mails aussitôt

Dans comptes avancé: cocher utiliser SSL (le port passe à 993 au lieu de 143) Authentification cocher externe(client TLS)

Revenir à Données du compte cocher dans Certificat TLS celui produit par le système "com.apple.idms.XXXXXXX"

Ces éléments sont nouveaux depuis Yosemite

Et je suis de nouveau déconnecté... Y a t il qqch à faire au niveau de free?

Share this post


Link to post
Share on other sites

Suite

j'ai essayé SSL port 465 après avoir modifié l'authentification sur l'interface de gestion. Pas de résultat. 

Mon macbook toujours sur mavericks et mon iphone envoient des mails sans problème non SSL sur le port 25. Ce réglage ne fonctionne pas sous Yosemite sur mon Mac mini: pas de connexion au serveur SMTP free.fr

Problème de compatibilité entre free et Yosemite?

Share this post


Link to post
Share on other sites

Fin. Résolu

Il faut aller dans modifier le liste des serveurs et si pas de SSL entrer le port 25 et cocher la case "détecter automatiquement et préserver les réglages"

Share this post


Link to post
Share on other sites

Bonjour

 

Moi j'ai résolu le problème différemment. Il faut aller sur l'interface free et désactiver le blocage du SMTP sortant ( ce qui semble une nouvelle option activée par défaut.)

Après tout marche à nouveau pour moi.

Share this post


Link to post
Share on other sites

Bonjour

 

mon problème, à moi, n'est pas tant d'envoyer car j'aimerais déjà pouvoir recevoir ! Aucun mails de free ne veut se connecter alors que gmail fonctionne

j'ai tenté les modifications indiquées ici mais rien ne fonctionne

qui aurait une solution ?

merci

Share this post


Link to post
Share on other sites

Bonjour,

 

 Aucun mails de free ne veut se connecter alors que gmail fonctionne

 

Avez-vous accès au moins à votre compte mail ?

Avez-vous  la  possibilité de  consulter  vos  emails  ...

Share this post


Link to post
Share on other sites

ailleurs oui car j'ai fait une install de Yosemite sur un disque externe et j'ai conservé la version précédente de l'Os et là, Mail reçoit bien mes messages. je précise que j'ai changé tous mes MDP cette semaine mais, toujours sur Mountain, je les reçois correctement

Share this post


Link to post
Share on other sites

bonjour,

mes mails restent bloqués en smtp depuis le passage a yosemite. Pas toujours mais souvent...?

port 465 SSL. qui régulièrement est effacé par le systèmes....

Vraiment très pénible....

Imap meme problème au début en 993SSL mais maintenant OK.stable.

Une idée?

J'ai essayé d'autres ports mais ne marchaient pas mieux...

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai résolu mon problème de connexion en IMAP (donc pour recevoir le courrier) à mes comptes free en cochant la case "Autoriser l'authentification non sécurisée" dans les préférences de Mail, Comptes, Avancé :

 

post-5285-0-72512400-1416150135_thumb.pn

Share this post


Link to post
Share on other sites

Merci pour vos informations qui semblent m'avoir permis de résoudre le problème de non stabilité des paramètres de compte mail free.
Depuis Yosemite, j'ai du activer la sécurisation SSL (port 993). Je le faisais via les paramètres accessibles via mail.
J'ai découvert que le paramètre du compte internet lié à free, n'avait pas enregistré cette option SSL et le port. 
J'ai donc enregistré cette option via les préférences systèmes / comptes internet / mon compte free / Avancé : imap.free.fr  port 993 option SSL.
Bon courage et bonne continuation à vous

Share this post


Link to post
Share on other sites

Bonjour a tous, 

 

"heureux" de voir qu'on est plusieurs à avoir le meme pbavec les comptes email Free depuis la dernier maj de l'OS Yosemite... ;-)

 

Effectivement, enregistrer l'option SSL et le port 993 fonctionne mais je ne sais pas pourquoi après quelques jours, le pb est de nouveau présent : impossible de recevoir mes emails et il faut de nouveau refaire le meme paramétrage... C'est vraiment galère...

 

J'ai essayé avec et sans l'option "Détécter automatiquement et préserver les réglage de compte"/dans les paramètres de compte email mais le résultat est le meme : s'est instable dans le temps...

 

Si quelqu'un a trouvé la solution miracle, je suis preneur... Merci pour son aide...

Share this post


Link to post
Share on other sites

Bonjour a tous, 

 

"heureux" de voir qu'on est plusieurs à avoir le meme pbavec les comptes email Free depuis la dernier maj de l'OS Yosemite... ;-)

 

Effectivement, enregistrer l'option SSL et le port 993 fonctionne mais je ne sais pas pourquoi après quelques jours, le pb est de nouveau présent : impossible de recevoir mes emails et il faut de nouveau refaire le meme paramétrage... C'est vraiment galère...

 

J'ai essayé avec et sans l'option "Détécter automatiquement et préserver les réglage de compte"/dans les paramètres de compte email mais le résultat est le meme : s'est instable dans le temps...

 

Si quelqu'un a trouvé la solution miracle, je suis preneur... Merci pour son aide...

Je confirme, de temps en temps l'option SSL se décoche tout seul... Y'a un blem chez Apple, il serait temps qu'ils corrigent...

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

De mon côté, les soucis avec le smtp Free sont un peu différent: sous Yosemite avec "Mail", Safari, Maxthon, je peux envoyer seulement des mails simples. Par contre, il m'est impossible de transférer les messages, envoyer des mails avec une ou des pièces jointes et de cliquer "répondre à". L'envoi échoue systématiquement malgré la vérification des paramètres smtp Free.

 

Pas de problèmes pour recevoir les mails en IMAP.

 

Une solution???

Share this post


Link to post
Share on other sites

Le 26 novembre, je vous faisais part d'une solution qui semblait avoir Aiglemont problèmes de stabilité de paramètres avec le compte free.

 Cette solution n'a pas tenu dans le temps et aujourd'hui, je me retrouve avec les mêmes difficultés.

Je donc le regret pour moi et pour vous de ne pas savoir comment régler ce problème.

Bon courage bonne continuation à vous.

Share this post


Link to post
Share on other sites

Beaucoup de soucis avec ce bogue récent… Je viens d'en discuter sur le forum du Club Mac de Montréal, ici.

 

Une solution expliquée ici, en anglishe… et ici, en français de France, sur Macbidouille.

 

Bonne chance!

Edited by François Boucher

Share this post


Link to post
Share on other sites

Salut,

 

J'avais le même problème. Par chance, plusieurs comptes fonctionnent d'habitude. Plusieurs furent impossibles à connecter, un seul resta opérationnel.

La comparaison donna la différence suivante :

 

Dans le compte opérationnel, la case "AUTORISER L'AUTHENTIFICATION NON SÉCURISÉE" fut cochée.

En cochant cette case dans les autres comptes, le pb fut résolu.

 

Bien cordialement

danixx69

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...