Jump to content
Free-reseau.fr - Les forums

Option Wake On Lan non disponible


Go to solution Solved by CoolRaoul,

Recommended Posts

Bonjour, 

Tout d'abord c'est mon premier post j'espère que je suis au bon endroit et que je ne fais pas de doublon. 

Je viens enfin de changer de pc et j'en ai un ou je peux utiliser le Wake On Lan. Je me connecte régulièrement sur mon pc à la maison quand je suis à l'extérieur et j'avais donc l'habitude de le laisser allumer (pas ouf comme option). 
J'ai donc configuré le WOL sur mon pc et j'arrive à le faire marcher avec une app dédié sur mon tel. Je laisse le pc en veille, j'appuiesur mon bouton, il s'allume et c'est super. 
Le problème est que sur cette application l'ip paramétrée est locale donc ça ne marche que quand je suis chez moi. Ce qui n'est pas très utile. 

Il me faut donc un moyen de faire la même chose depuis l'extérieur. Plutôt que de bidouiller des redirections de ports et autre avec les risques de sécurité qui vont avec et vu que je ne suis pas un expert du domaine j'aurais aimé utiliser l'option disponible par défaut sur l'application Freebox connect. J'ai donc activé cette option dans les paramètres avancés eeeeet...

C'est là que j'ai un problème. Mon pc apparaît comme connecté dans la liste des appareils sur le réseau, alors qu'il est en veille. Et l'option WOL n'est visiblement disponible que pour les appareils déconnectés (cf. captures)

Est ce que c'est l'application qui est faite avec les pieds ? Est ce que mon pc doit être éteint et pas en veille (bizarre) ? Est ce que j'ai foiré un de mes paramétrages ?

Je dois avouer être un peu perdu. 

 

Liste_appareils.jpg

Un_appareil_co.jpg

Un_appareil_deco.jpg

Link to comment
Share on other sites

  • Weezenger changed the title to Option Wake On Lan non disponible

Bonjour

Vous interrogez la Freebox à distance (via l app) qui allume en WOL un équipement local (et donc avec son IP locale) donc tout est normal et cela fonctionnera comme cela.

Pour le statut de l ordi, il faut vérifier les options de windows et bios et être bien sur que le PC est ready a recevoir les requêtes WOL..

A noter, qu'il y a une latence et le passage en HORS LIGNE demande quelques minutes généralement parce que la carte réseau est en veille. pas tout à fait éteinte, pas tout à fait allumée

Link to comment
Share on other sites

  • Solution
Posted (edited)
Il y a 3 heures, Weezenger a dit :

J'ai donc configuré le WOL sur mon pc et j'arrive à le faire marcher avec une app dédié sur mon tel. Je laisse le pc en veille, j'appuiesur mon bouton, il s'allume et c'est super. 
Le problème est que sur cette application l'ip paramétrée est locale donc ça ne marche que quand je suis chez moi. Ce qui n'est pas très utile. 

J'avoue être un peu perplexe de te voir parler d'addresse IP dans un contexte de Wake on LAN.

Ce protocole cible l'adresse *MAC* et pas l'IP, ce qui fait sens étant donné que lorsque le PC est en veille et à fortiori arrêté, le protocole IP est inactif sur ce dernier.

Le WOL consiste à envoyer un paquet UDP avec une address IP de type broadcast qui est capturée par la carte elle-même. Si elle est convenablement configurée elle reste en "semi sommeil" et sait réagir à ce type de paquet spécifique ("magic paquet") si elle est correctement configurée (et  c'est le cas puisque tu confirme que ça fonctionne en local)

Pour que ça fonctionne aussi depuis l'extèrieur il faut en premier lieu que le proxy WOL soit activé sur les paramètres de ta ligne. Ensuite (même si je ne suis pas certain à 100% de cette condition) que tu dispose d'une IP fixe de Fullstack (ce qui se configure au même endroit)

Pour ma part j'utilise cette application sur Android : Wake On Lan

Voici sa configuration telle qu'elle fonctionne chez moi

image.png.5558f7f87fc188f1504ac312a67fd072.png

  • Adresse MAC : l'addresse MAC de la carte ethernet du PC
  • Nom d'hôte/IP/Adresse de diffusion : addresse IP V4 publique de ta box (d'ou le pre-requis d'une IP fixe)
  • le numéro de port doit impérativement être 9

les autres options sont sans importance.

pas de redirection de port à mettre en place, c'est l'OS de la Freebox qui se charge de router le paquet reçu sur l'interface externe sur sa pate interne avec l'addresse broadcast du LAN local

Tu peux ajouter une 2eme configuration à utiliser en local dans laquelle tu mettras l'addresse IP de broadcast locale, qui dépend de la conf de ta Freebox mais doit être du genre 192.168.1.255 et la même MAC.

Coté PC il faut s'assurer d'avoir activé les deux options ci-dessous (c'est déjà le cas chez toi si ça marche en local mais ça peut être utile à d'autres): 

  • Sous Windows, au niveau de la carte : (j'ai aussi activé le "Wake on Pattern match" même si je ne suis pas certain que ca soit necessaire). Les désignation et l'apparence de ce panneau de configuration peuvent varier selon le type de carte ethernet et la version du driver.
    Il doit y avoir l'équivalent sur Mac mais je ne connais pas.
    image.png.91c7d76f256aa0c40d2c4e0f5a867025.png
  • Au niveau des paramètres d'alimentation, le démarrage rapide doit être désactivé : image.png.51368a8ad5dcaf054f318edf5cf35869.png
Edited by CoolRaoul
Link to comment
Share on other sites

il y a 32 minutes, CoolRaoul a dit :

(j'ai aussi activé le "Wake on Pattern match" même si je ne suis pas certain que ca soit necessaire)

Je viens de chercher un peu des infos sur cette option. Il s'avère que la laisser activée peut avoir un effet non souhaité de voir le PC se réveiller quand il est en veille selon ce qui se passe sur le réseau.

Je l'ai donc désactivé. Ensuite vérifié PC éteint que le Wake On LAN continue à fonctionner. Je confirme que c'est le cas.

Edited by CoolRaoul
Link to comment
Share on other sites

Posted (edited)

Bonjour à tous,

Tout d'abord merci pour vos réponses. Je vais essayer de répondre de manière claire à tout le monde.
 

Le 17/04/2024 à 17:34, Admin Free-reseau a dit :

Pour le statut de l ordi, il faut vérifier les options de windows et bios et être bien sur que le PC est ready a recevoir les requêtes WOL..

Je pense que les options sont ok car j'arrive bien à réveiller le pc avec une autre app que celle de Free (mais cette app ne marche que quand je suis chez moi bon grâce à CoolRaoul j'ai la solution pour la faire marcher depuis l'extérieur, c'est pas ce que je voulais de base mais ça résous quand même mon problème de fond). 

Le 17/04/2024 à 17:34, Admin Free-reseau a dit :

A noter, qu'il y a une latence et le passage en HORS LIGNE demande quelques minutes généralement parce que la carte réseau est en veille. pas tout à fait éteinte, pas tout à fait allumée

Je m'en doutais mais là même après une nuit entière en veille mon PC reste affiché comme étant connecté. J'imagine que le problème se situe ici du coup. 
Après ça aurait été pratique d'avoir l'option d'envoyer le paquet même sur des appareils affichés comme connecté pour éviter ce genre de problématiques. 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Le 17/04/2024 à 18:45, CoolRaoul a dit :

J'avoue être un peu perplexe de te voir parler d'addresse IP dans un contexte de Wake on LAN.

Ce protocole cible l'adresse *MAC* et pas l'IP, ce qui fait sens étant donné que lorsque le PC est en veille et à fortiori arrêté, le protocole IP est inactif sur ce dernier.

Le WOL consiste à envoyer un paquet UDP avec une address IP de type broadcast qui est capturée par la carte elle-même. Si elle est convenablement configurée elle reste en "semi sommeil" et sait réagir à ce type de paquet spécifique ("magic paquet") si elle est correctement configurée (et  c'est le cas puisque tu confirme que ça fonctionne en local)

Désolé si la terminologie n'est pas parfaite je découvre à peine le sujet. Je pensais que le magic packet était associé à une IP et qu'on envoyait ça un peu comme un ping.
J'ai d'ailleurs un bail fixe sur l'IP de mon pc (bon il ne me sert pas qu'à ça donc je vais le garder mais je m'égare). 

Effectivement je pense que la conf du pc est ok. 
 

Le 17/04/2024 à 18:45, CoolRaoul a dit :

Pour ma part j'utilise cette application sur Android : Wake On Lan

Ah bah j'ai justement la même application, c'est sur celle-là que j'ai fait le test en local. 

Merci pour le tuto, j'avais effectivement tout bien paramétré. Y'a que le "Wake on Pattern match" que je n'avais pas mais si tu me dis que c'est pas nécessaire je vais laisser ça comme ça. 

S'il n'y a pas de redirection de port à faire et vu que j'ai déjà une IP publique fixe je vais sans doute me faire une 2e conf "extérieure" dans Wake On Lan.
C'est dommage car ça m'oblige à avoir une application juste pour cette fonctionnalité alors que c'est censé être inclus dans l'application Free mais bon. Si c'est le seul moyen de le faire marcher. 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Edit pour d'autres qui arriveraient ici :
La solution de Raoul marche très bien encore merci à lui

J'ai pas de mac donc je peux pas faire de retour là-dessus.
Et autre info je fais ça en wifi (car à ma grande déception mon proprio a mis des prises RJ45 partout dans l'appart mais elles ne sont branchés à rien 🤦‍♂️) donc pour ceux qui se posent la question ça se fait aussi en wifi !

Edited by Weezenger
  • Like 1
Link to comment
Share on other sites

Pourquoi cela ne fonctionnerait pas en wifi ?

c'est un "paquet magique"  envoyé sur une carte réseau en semi veille.

après quid de la batterie pour les portables parce que du coup, ca consomme forcement mais une carte WIFI sur un PC

 

Link to comment
Share on other sites

il y a une heure, Admin Free-reseau a dit :
Pourquoi cela ne fonctionnerait pas en wifi ?
c'est un "paquet magique"  envoyé sur une carte réseau en semi veille.
après quid de la batterie pour les portables parce que du coup, ca consomme forcement mais une carte WIFI sur un PC

C'est que j'ignorais totalement qu'une carte wifi, contrairement à une carte ethernet, était capable de rester en veille active.
En plus pour recevoir les paquets "magiques" elle doit avoir une bonne partie du protocole WiFi activé dans cette configuration (en particulier l'authentification)

**edit**

Et en effet ça semble possible (dans la mesure ou la carte le supporte).

J'aurais appris un truc aujourd'hui !

Edited by CoolRaoul
Link to comment
Share on other sites

Il y a 17 heures, CoolRaoul a dit :

Le PC que tu réveille est connecté uniquement en WiFi ?

Oui wifi seulement (à mon grand dam)

Il y a 1 heure, Admin Free-reseau a dit :

après quid de la batterie pour les portables

J'avoue que je le tenterais pas sur un portable, mais sur mon pc fixe c'est pas bien grave. 

Link to comment
Share on other sites

  • 3 weeks later...

Bonjour, Je viens de passer pas mal de temps pour comprendre pourquoi ça ne marche pas. (Mais maintenant ça marche !)
J'ai remplacé ma carte à base d'INTEL 520, qui fonctionnait bien mais n'avait pas la fonction Wake On LAN par celle-ci, attention c'est la XG-C100F (la XG-C100C n'offre pas de WoL).
Cette carte est reliée pas un câble AOC ElfCam à un switch QNAP QSW 2014-2S et celui-ci par un même câble à ma FreeBox Ultra.
Pour pouvoir se servir du WoL, il y a 3 étapes :
1- la carte, dans "gestionnaire de périphériques" sélectionner la carte puis dans les Propriétés, dans l'onglet "Avancés", en bas de la liste déroulante, sélectionner Wake on LAN Packet Magic et choisir "Enabled"
2- le BIOS, problème ils sont tous un peu différents, dans le MSI, choisir le mode "avancé" avec F7 ou la souris. Et là il y a un piège, vous aviez peut-être déjà validé le WoL pour le port RJ45 de la carte mère mais n'oubliez pas que la carte fait partie des périphériques PCIe et il y a une ligne spéciale pour autoriser les accessoires PCIe à réveiller l'ordi.
3- La Box, très simple dans le menu Freebox OS, mode avancé, Configuration, cocher le case Proxy Wake On LAN
Voilà, vous pouvez allumer l'ordi depuis un autre PC ou le Smartphone (Freebox Connect) ou avec un logiciel comme celui de Damien PONNELLE.
Bon réseau !
P'tit Geo

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...