Jump to content
Free-reseau.fr - Les forums

Recommended Posts

Bonjour,

Depuis 3 semaines environ, je rencontre un problème en IPV6 ( pas en IPV4).

Les connexions TCP,UDP ou ICMP ne fonctionnent plus, même vers l'infrastructure de free :

  • ping
ping6 -c 2 www.free.fr
PING6(56=40+8+8 bytes) 2a01:xxxx:xxxx:xxxx::xxxx --> 2a01:e0c:1::1

--- www.free.fr ping6 statistics ---
2 packets transmitted, 0 packets received, 100.0% packet loss
  • connexion tcp/http ( www.kame.net)
curl -6 www.kame.net
curl: (7) Failed to connect to www.kame.net port 80: Operation timed out
  • connexion tcp/ftp (ftp.free.fr)
ftp -6 www.free.fr
ftp: Can't connect to `2a01:e0c:1::1:21': Operation timed out
  • connexion udp (serveur DNS de free)
dig www.google.fr @2a01:e00::1

;; connection timed out; no servers could be reached

Par contre, je peux joindre d'autres freebox ou me connecter à des machines hebergées derrière celles-ci, toujours en IPV6 :

  • ping
traceroute6 2a01:yyy:yyyy:yyyy:yyyy:yyy:yyy:machineDistante
traceroute6 to 2a01:yyy:yyyy:yyyy:yyyy:yyy:yyy:machineDistante from 2a01:xxxx.xxxx.xxxx:xxxx:xxxx:xxxx:maMachine, 64 hops max,12 byte packets
1  2a01:maFreebox::1  1.624 ms  1.669 ms  1.305 ms
2  2a01:freeboxDistante::1  51.147 ms  51.519 ms  51.640 ms
3  2a01:yyy:yyyy:yyyy:yyyy:yyy:yyy:machineDistante  55.176 ms  54.412 ms  53.197 ms

La seule différence est que les freebox se voient directement (ou le semblent) , sans routeur intermédiaire.

Je soupçonne donc un problème de routage.

Soit les routes affectées à ma freebox ne sont pas bonnes, soit un routeur de free est défectueux, mais je pense que cela aurait été remarqué.

Je ne sais pas comment établir un meilleur diagnostic car il n'est pas possible d'accéder à la configuration réseau ou aux logs de la freebox.

Depuis, la freebox a été remplacée et un technicien est passé, mais sans effet.

Auriez-vous des informations, des idées, des retours d'expérience ?

Merci d'avance :-)

Link to post
Share on other sites

Ça ressemble à soucis de route de retour, si vous avez un firewall (ce qui est fortement recommandé en ipv6 chez free), vérifiez que vous ne bloquez pas les annonces NDP et les protocoles de découverte : fe80::/10 et ff00::/8, icmpv6 types 128 à 129 et 133 à 136 et dhcpv6 (udp 546 et 547)

=>le plus simple c'est d'activer les logs des paquets bloqués en udp et en icmpv6 (entrant et sortants)

Si votre routeur v6 ne reçoit plus de signe de vie de votre par ou est incapable de vous contacter, il supprime la route (ce qui est normal en adressage dynamique).

Link to post
Share on other sites

Bonjour et merci pour cette réponse.

Effectivement, j'utilise un firewall routeur mais les annonces et sollicitations NDP sont bien autorisées.

À vrai dire, j'ai même testé en connectant directement un PC sur la freebox, sans mon routeru firewall donc, et le résultat est le même.

Mais j'ai remarqué autre chose. D'après une requête whois, le range ipv6 attribué à FREE est le 2a01:e00/26, ce qui couvre les IP allant de 2a01:e00:0:0:0:0:0:0 à 2a01:e3f:ffff:ffff:ffff:ffff:ffff:ffff.

Le préfixe qui m'est attribué commence par 2a01:e35, tandis que celui d'un ami (qui n'a pas le souci) commence par 2a01:e34.

Or si l'on teste un traceroute6 en ligne (http://www.traceroute6.net/ ) on constate une différence fondamentale au niveau des routes :

  • traceroute vers ma freebox (
traceroute to 2a01:e35:mafreebox::1 (2a01:e35:mafreebox::1), 30 hops max, 80 byte packets
 1  hv302.nl1.bhost.net (2a04:ad80::bec6:c021)  0.163 ms  0.030 ms  0.026 ms
 2  10gigabitethernet1-1-3.switch1.ams2.he.net (2001:470:1:2ed::1)  1.454 ms  1.460 ms  1.411 ms
 3  100ge9-1.core1.lon2.he.net (2001:470:0:2d0::1)  7.402 ms  7.349 ms  7.458 ms
 4  2001:7f8:4::3022:1 (2001:7f8:4::3022:1)  8.314 ms  8.252 ms  8.203 ms
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *

et cela continue ainsi jusqu'au 30ème hop.

Un ping6 indique 100% de paquets perdus.

  • traceroute vers la freebox d'un ami (2a01:e34)
traceroute to 2a01:e34:saFreebox::1 (2a01:e34:saFreebox::1), 30 hops max, 80 byte packets
 1  hv302.nl1.bhost.net (2a04:ad80::bec6:c021)  0.106 ms  0.030 ms  0.027 ms
 2  10gigabitethernet1-1-3.switch1.ams2.he.net (2001:470:1:2ed::1)  0.478 ms  0.437 ms  0.390 ms
 3  100ge9-1.core1.lon2.he.net (2001:470:0:2d0::1)  13.863 ms  13.880 ms  13.853 ms
 4  2001:7f8:4::3022:1 (2001:7f8:4::3022:1)  8.418 ms *  8.589 ms
 5  * * *
 6  p11-crs16-1-be2000.intf.routers.proxad.net (2a01:e00:17:1::2)  15.609 ms  14.993 ms  17.459 ms
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *

Cela continue ainsi jusqu'au 30ème hop, mais on voit ici en position 6 un routeur de FREE.

Et dans ce cas le ping6 fonctionne parfaitement.

 

Cela renforce l'idée d'un problème de routage, mais je ne sais pas si cela vient de FREE ou de Hurricane Electric ici.

J'ai essayé pas mal d'autres préfixes ( e10 e20 e26 e33 e37 ) et le routeur de free n'est jamais atteint.

J'ai l'impression que seul le 2a01:e34 est utilisable.

 

Votre préfixe commence-t-il par par 2a01:e34 ?

Quelqu'un connaîtrait une personne chez FREE susceptible de remonter ce point ? Le support n'a pas voulu m'écouter.

 

Cordialement.

Link to post
Share on other sites

Mon préfixe est aussi en 2a01:e35, mais je ne suis pas en mesure de tester (chenillard lent depuis 1 mois !!). Avant mon soucis de connexion, ça marchait.

Il y a 14 heures, cvdl a dit :

mais je ne sais pas si cela vient de FREE ou de Hurricane Electric ici.

Si ça venait uniquement de HE, certaines adresses seraient accessibles (vous pouvez tester ipv6.fenrir.fr, c'est une dedibox, donc dans un autre préfixe de free). Vous pouvez aussi tester depuis un broker (autre que HE), sixxs par exemple.

Il y a 15 heures, cvdl a dit :

J'ai essayé pas mal d'autres préfixes ( e10 e20 e26 e33 e37 ) et le routeur de free n'est jamais atteint.

S'il n'y a pas d'équipement actif en face, ça ne peut pas marcher, il faut avoir des adresses attribuées et actives.

Vous pouvez aussi m'envoyer en mp des adresses valides en 2a01:e34 et e35, je testerai depuis différents réseaux (ovh, dedibox, renater, ...), ça permettra de voir si le soucis est le même, mais je pense que la réponse sera oui.

Sinon, avec un peu de chance, ma connexion sera rétabli dans la semaine (j'espère car je commence à trouver le temps long et je reste poli).

Pour ce qui est du support "classique" sur ce genre de sujet, à mon avis c'est sans espoir. Mais ça vaut le coup d'ouvrir un ticket sur le site (histoire de ne pas passer par la hotline), au moins ça laissera une trace écrite. Vous aurez peut être plus de chance avec les newsgroup, irc ou encore dev.freebox.fr. Les ingé free y passent de temps en temps.

Link to post
Share on other sites

bonjour,

je suis d'accord avec la majeure partie de l'analyse , mais je pense qu'il n'est pas nécessaire qu'un soit actif pour que le traceroute6 passe par "p11-crs16-1-be2000.intf.routers.proxad.net". Il s'arrêtera plus loin, c'est tout

Chose intéressante un autre utilisateur a ouvert le même ticket, mais sur de la fibre optique :

Les date correspondent exactement, je pense donc que le problème est bien chez FREE.

Je vais tenter de contacter free par les moyens que vous indiquez, merci :).

 

Link to post
Share on other sites

Bonjour,

oui cela ne semble pas lié à l'ADSL ou à la fibre, ni au quartier.
oui cela semble hors des compétences du 3244 que je viens d'appeler à nouveau.

il y a le bug 20719, posté sur dev.freebox.fr qui ressemble  http://dev.freebox.fr/bugs/task/20719
les dates correspondent, pour s’inscrire il faut son "Jabber ID" chaque client free en a-t-il un ? ou le trouve-t-on ?

Link to post
Share on other sites

Je viens de récupérer ma connexion après 1 mois de coupure, chez moi l'ipv6 fonctionne toujours :

ping6 -n -c 2 free.fr
PING free.fr(2a01:e0c:1::1) 56 data bytes
64 bytes from 2a01:e0c:1::1: icmp_seq=1 ttl=60 time=40.3 ms
64 bytes from 2a01:e0c:1::1: icmp_seq=2 ttl=60 time=39.4 ms

--- free.fr ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 39.409/39.868/40.328/0.501 ms
#########################################################################
ping6 -n -c 2 kernel.org
PING kernel.org(2001:4f8:1:10:0:1991:8:25) 56 data bytes
64 bytes from 2001:4f8:1:10:0:1991:8:25: icmp_seq=1 ttl=45 time=233 ms
64 bytes from 2001:4f8:1:10:0:1991:8:25: icmp_seq=2 ttl=45 time=230 ms

--- kernel.org ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 230.528/232.246/233.965/1.784 ms

Et mon préfixe est 2a01:e35:xxxx:xxxx::/64

edit : un petit traceroute depuis http://www.traceroute6.net/ vers mon routeur (freebox en bridge)

traceroute to 2a01:e35:xxxx (2a01:e35:xxxx), 30 hops max, 80 byte packets
 1  2001:2e8:665:0:2:2:0:1 (2001:2e8:665:0:2:2:0:1)  0.103 ms  0.077 ms  0.043 ms
 2  2001:2e8:22:204::2 (2001:2e8:22:204::2)  1.042 ms  0.968 ms  1.151 ms
 3  2001:2e8:20::22:11 (2001:2e8:20::22:11)  1.019 ms  0.914 ms  0.834 ms
 4  xe-0-6-0-11.r00.tokyjp01.jp.bb.gin.ntt.net (2001:218:2000:5000::1a9)  1.635 ms  1.456 ms  1.368 ms
 5  ae-8.r31.tokyjp05.jp.bb.gin.ntt.net (2001:218:0:2000::361)  1.259 ms  1.093 ms  0.993 ms
 6  ae-1.r23.snjsca04.us.bb.gin.ntt.net (2001:218:0:2000::d1)  117.305 ms ae-4.r23.snjsca04.us.bb.gin.ntt.net (2001:218:0:2000::51)  107.445 ms ae-4.r23.lsanca07.us.bb.gin.ntt.net (2001:218:0:2000::62)  110.302 ms
 7  ae-41.r02.snjsca04.us.bb.gin.ntt.net (2001:418:0:2000::f6)  117.084 ms  117.490 ms ae-2.r01.lsanca07.us.bb.gin.ntt.net (2001:418:0:2000::146)  109.511 ms
 8  be3052.ccr41.sjc03.atlas.cogentco.com (2001:550:3::ed)  117.725 ms be12914.ccr41.lax04.atlas.cogentco.com (2001:550:3::a5)  110.044 ms be3052.ccr41.sjc03.atlas.cogentco.com (2001:550:3::ed)  109.393 ms
 9  be2000.ccr21.sjc01.atlas.cogentco.com (2001:550:0:1000::9a36:669)  109.882 ms be2047.ccr22.sjc01.atlas.cogentco.com (2001:550:0:1000::9a36:571)  105.434 ms be2965.ccr22.lax01.atlas.cogentco.com (2001:550:0:1000::9a36:2d01)  111.234 ms
10  be2164.ccr21.sfo01.atlas.cogentco.com (2001:550:0:1000::9a36:1c21)  110.207 ms  111.547 ms be2165.ccr22.sfo01.atlas.cogentco.com (2001:550:0:1000::9a36:1c41)  109.310 ms
11  be2086.ccr21.slc01.atlas.cogentco.com (2001:550:0:1000::9a36:3ba)  125.698 ms be2929.ccr21.elp01.atlas.cogentco.com (2001:550:0:1000::9a36:2a42)  129.384 ms *
12  be3037.ccr21.den01.atlas.cogentco.com (2001:550:0:1000::9a36:2992)  151.273 ms  151.112 ms be2927.ccr21.iah01.atlas.cogentco.com (2001:550:0:1000::9a36:1ddd)  147.446 ms
13  be2687.ccr41.atl01.atlas.cogentco.com (2001:550:0:1000::9a36:1c45)  164.243 ms * *
14  be2112.ccr41.dca01.atlas.cogentco.com (2001:550:0:1000::9a36:79d)  174.897 ms  173.736 ms *
15  be2806.ccr41.jfk02.atlas.cogentco.com (2001:550:0:1000::9a36:2869)  160.073 ms * *
16  be2746.ccr41.par01.atlas.cogentco.com (2001:550:0:1000::9a36:1d76)  234.225 ms be2878.ccr21.alb02.atlas.cogentco.com (2001:550:0:1000::9a36:1a82)  164.341 ms be2746.ccr41.par01.atlas.cogentco.com (2001:550:0:1000::9a36:1d76)  234.376 ms
17  be2299.ccr21.bos01.atlas.cogentco.com (2001:550:0:1000::9a36:2b09)  166.640 ms 2001:978:2:19::11:2 (2001:978:2:19::11:2)  261.420 ms  261.620 ms
18  * * *
19  be12497.ccr41.par01.atlas.cogentco.com (2001:550:0:1000::9a36:3882)  237.111 ms  237.348 ms *
20  * * *
21  * * *
22  2a01:e35:xxxx (2a01:e35:xxxx)  305.931 ms  303.641 ms  307.254 ms

 

Edited by fenrir
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...